.htacces features in addon domain.


Jul 7, 2008
Hello gy's

Im having some dificulty, using my .htaccess rules ive always used on difrent systems. The problem coud be that im not in the root folder acording to cpanel. Its a add on not the main domain.

This is how it is at the moment

/public_html/"the main site here"/"my site here"/

and I wanna use the following htacces like I always have.

RewriteEngine On
RewriteBase /
RewriteCond %{http_host} ^animeresource.org [nc]
RewriteRule (.*)$ http://www.animeresource.org/$1 [r=301,nc]

RewriteRule ^f([0-9]+)(.*).html$ viewforum.php?id=$1 [L]
RewriteRule ^t([0-9]+)(.*).html$ viewtopic.php?id=$1 [L]
RewriteRule ^p([0-9]+)(.*).html$ viewtopic.php?pid=$1 [L]
RewriteRule ^(.*).rss$ extern.php?action=$1&type=rss [L]
RewriteRule ^index.html$ index.php [L]
RewriteRule ^forum.html$ forum.php [L]
RewriteRule ^download.html$ download.php [L]
RewriteRule ^streaming.html$ page.php?id=4 [L]
RewriteRule ^animeradio.html$ page.php?id=266 [L]

ErrorDocument 401 /include/401.html
ErrorDocument 403 /include/403.html
ErrorDocument 404 /include/404.html

Im not a expert in .htacces but I found when I put it in my directory it dusent work or dusent take effect or gives a 505. When I put it in the root it dusent give 505 but ofcourse since its not in my directory it dusent have any effect. Coud someone help me point it to the following directory ?


I want that location to be effected with my .htaccess script coud someone please help me out with this one or I wont be able to use cpanel... :eek:


Active Member
Nov 10, 2004
Western US
I'm having the same problem where the mod_rewrite is being ignored in .htacess unless I use:

Options +FollowSymlinks


Xbithack on

where either will thru a 500 error, then teh rest of the time, it seems to ignore the rewrite rules and conditions.

I've search high and low in the cpanel forums, and many files for httpd for over 12 hours straight now, and nothing works that has been suggested and/or historically has worked for years. Also, I've noticed that around the time cpanel enabled mod-rewrite by default that a lot of people have had problems with this same issue and nearly every single post , except one or two without real solutions, drop off into the unanswered category.

It doesn't matter what I work with combination wise, nothing works in regards to using mod_rewrite within .htaccess in every cpanel config'd server I tried using any combination of 11.23.x with Centos 4.6 or Centos 5.x, apache 1.3.41, or apache 2.2.9, etc.

I've given it my best shot to figure it out without adding yet another post to the subject :)

So, as a last resort, I'm wondering if someone knows how to get mod_rewrite to work within .htaccess under newer cpanel configs? Not the actual code, as even simple things do not work at all in htaccess, yet htaccess does work, as does the cpanel rewrite rules I've found.